ITKP101-Harjoitustyö

1. Asiakirjan kieleen liittyvät työkalut

Tekstinkäsittelyohjelmista löytyy muutamia hyödyllisiä kieleen liittyviä työkaluja. Kieleen liittyvät työkalut ovat riippuvaisia ohjelmaan asennetuista kielipaketeista. Esimerkiksi englanninkielisessä Microsoft Officessa on käytössä pelkästään englanninkieli, mutta suomenkielisessä ohjelmissa on käytössä sekä suomen- että englanninkieli. Jos ohjelmasta ei löydy halutun kielen tukea, niin sellainen täytyy hankkia erikseen. Seuraavissa luvuissa esitellään lyhyesti asiakirjan kieleen liittyviä työkaluja ja niiden käyttöä. 

1.1. Tyylien kielen valinta

Kielen valinta kannattaa tehdä tyyleihin, jolloin sitä ei tarvitse määrittää enää erikseen. Kielen valinta onnistuu tyylin ominaisuuksien muokkaamistilasta valikkokomennolla Format | Language. Valintaikkunasta voidaan valita myös tarkastetaanko automaattisesti oikeinkirjoitusta ja kielioppia (engl. Do not check spelling or grammar). Jos käytössä on halutun kielen tuki, niin tarkistus kannattaa pitää päällä. Toinen mahdollisuus kielen määrittämiseen on valita haluttu kohta tekstistä ja valita kieli valikkokomennolla Tools | Language | Set Language. Komennolla avautuu näkyville samankaltainen ikkuna kuin kielen valinnassa tyylistä. 

1.2. Oikeinkirjoituksen tarkastaminen

Asiakirjaa  kirjoitettaessa on usein hyödyllistä, jos asiakirjan oikeinkirjoitus tarkastetaan automaattisesti. Oletuksena oikeinkirjoituksen tarkistaminen pitäisi olla päällä, mutta se on voitu kytkeä pois päältä. Oikeinkirjoituksen automaattinen tarkistaminen voidaan asettaa päälle valikkokomennolla Tools | Options -avautuvan ikkunan Spelling and Grammar (suom. Kieliasun tarkistus) –välilehdeltä. Ylimpänä kohtana on Check spelling as you type (suom. Tarkista oikeinkirjoitus kirjoitettaessa), jonka täytyy olla valittuna kirjoituksen automaattiseksi tarkastamiseksi.

1.3. Oikeinkirjoituksen korjaukset

Oikeinkirjoituksen tarkistaminen alleviivaa väärinkirjoitetut sanat punaisella aaltoviivalla. Voit korjata sanan käsin tai voit antaa ohjelman hoitaa korjaamisen. Napauttamalla hiiren oikealla painikkeella virheellistä sanaa saadaan näkyville valikko, josta voidaan valita oikea sana virheellisen tilalle. Esimerkin tapauksessa valitaan sana kirjoitusvirheestä ja valittu sana korvaa väärän sanan. Voit käyttää sanan korjaamiseen myös automaattista korjausta (engl. Auto Correct), jolloin sana korjataan automaattisesti oikeaan muotoon, jos se kirjoitetaan väärin. Jos sana on kirjoitettu mielestäsi oikein, mutta oikeinkirjoituksen tarkistus pitää sanaa vääränä, niin voit lisätä sanan omaan sanastoosi, jolloin sitä ei enää merkitä vääräksi. Sanan lisääminen sanastoon onnistuu Add (suom. Lisää) -painikkeella. Valinnalla Spelling (suom. Oikeinkirjoitus) päästään oikeinkirjoituksen tarkistusikkunaan. Tarkistusikkunassa voidaan tarkistaa koko dokumentin oikeinkirjoitus. Tarkistusikkunan saa avattua myös valikkokomennolla Tools | Spelling and Grammar. Tarkistusikkunan yläosassa näytetään asiakirjan ensimmäinen kohta, joka ei löydy sanastosta. Ikkunan alaosasta voidaan valita virheellisen sanan tilalle korvaava sana. Ikkunasta on valittavissa seuraavat toiminnot:
  •  Ignore-painikkeella voidaan ohittaa kyseisen sanan ja jatkaa tarkistamista.
  •  Ignore All -painike voidaan ohittaa kaikki kyseisen sanan esiintymät.
  •  Sana voidaan lisätä käyttäjän sanastoon Add-painikkeella.
  •  Change-painikkeella muutetaan virheellisen sanan tilalle valittu sana.
  •  Change All-painike muuttaa kaikki kyseisen sanan esiintymät toisiksi.
  •  AutoCorrect-painikkeella asetetaan sana automaattisesti korjattavien sanojen joukkoon.

1.4. Kieliopin tarkastaminen

Kieliopin tarkastaminen on hyvin samankaltainen toimenpide kuin oikeinkirjoituksen tarkastaminen. Erona kieliopin tarkastamisessa on, että kieliopin mukaan virheelliset kohdat korostetaan vihreällä aaltoviivalla. Kieliopin (engl. Grammar) tarkistaminen onnistuu ainoastaan englanninkielisissä teksteissä. 

1.5. Oikeinkirjoituksen ja kieliopin tarkastuksen mukauttaminen

Oikeinkirjoituksen ja kieliopin tarkastusta voi mukauttaa muutamilla asetuksilla. Asetusten mukauttaminen onnistuu valikkokomennolla Tools | Options avautuvan ikkunan Spelling and Grammar -välilehdeltä. Asetukset saa näkyville myös oikeinkirjoituksen tarkistusikkunan Options-painikkeella. 

1.6. Synonyymisanaston käyttäminen

Synonyymisanaston käyttäminen voi olla hyödyllistä, jos halutaan elävöittää tekstiä tai jos haetaan asiaa paremmin kuvaavaa sanaa. Synonyymisanastoon on koottu samaa tai päinvastaista asiaa tarkoittavia sanoja, joita voidaan käyttää esimerkiksi käyttää toisissa asiayhteyksissä. Esimerkissä haetaan esimerkki-sanalle synonyymejä. Sanan synonyymit saadaan näkyville hiiren oikean painikkeen alta näkyviin tulevasta synonyms-valikosta. Valikossa voi olla näkyvillä suoraan synonyymisanoja tai sanoja voidaan etsiä tarkemmin Thesaurus-valinnalla, jolla avautuu näkyville erillinen ikkuna synonyymisanojen määrittämiseen. Toinen vaihtoehto sanan synonyymien etsimiseen on valikkokomento Tools | Language | Thesaurus. Näkyville avautuneen ikkunan vasemmassa reunassa on nähtävillä sana ja sen merkitykset (engl. Meanings). Kun jokin sanan merkitys valitaan, voidaan ikkunan oikeasta laidasta valita merkitystä vastaava synonyymi. Tällä tavalla voidaan etsiä parhaiten asiayhteyteen sopiva sana. Kun haluttu synonyymi on valittu, voidaan sana korvata synonyymilla Replace-painikkeella. Jos oikeaa sanaa ei tunnu löytyvän, niin voidaan edelleen hakea valitun synonyymin synonyymisanoja LookUp-painikkeella.

1.7. Tavutuksen käyttäminen

Asiakirjojen tavuttaminen (engl. Hyphenation) on hyödyllinen ominaisuus asiakirjan tekstikappaleissa, jotka tasataan molempiin reunoihin. Tavutuksen avulla saadaan asiakirjasta viimeistellyn näköinen. Tavutusta kannattaa käyttää vasta juuri ennen asiakirjan tulostamista, koska asiakirjaan tehtävät muutokset muuttavat usein myös tavutusta. Seuraavassa käsitellään lyhyesti muutamaa erilaista tapaa tavuttaa asiakirja. Asiakirja voidaan tavuttaa automaattisesti. Automaattinen tavutus saadaan päälle valikkokomennolla Tools | Language | Hyphenation avautuvasta ikkunasta. Ikkunasta voidaan valita määritellä asiakirja automaattisesti tavutettavaksi (engl. Automatically hyphenate document). Tällöin asiakirja tavutetaan automaattisesti vaikka sinne tulisi muutoksiakin. Ikkunasta voidaan säätää tavutusaluetta (engl. Hyphenation Zone). Tavutusalueelle jäävä tyhjä saa olla maksimissaan tavutusalueen mittainen tai muussa tapauksessa sana tavutetaan. Lisäksi voidaan valita tavutetaanko isolla kirjoitetut sanat ja peräkkäin tavutettavien rivien maksimilukumäärä. Manual-painikkeen avulla voidaan tavutus määritellä käsin. Käsin tavutettaessa voidaan tarkasti määrittää tavuviivan paikka sanassa. Ominaisuuden huono puoli on tavuviivakohtien jääminen asiakirjaan. Jos kappaleen sisältö muuttuu, niin tavuviivojen paikka muuttuu samalla. Tällöin tavuviivat jäävät tekstiin ja niiden poistamisesta aiheutuu ylimääräistä vaivaa. Tavuviivat eivät kuitenkaan näy sellaisenaan asiakirjassa, vaan ne näkyvät, kun asiakirjasta näytetään kaikki piilotetut merkit.
Skip to end of metadata
Go to start of metadata
#trackbackRdf ($trackbackUtils.getContentIdentifier($page) $page.title $trackbackUtils.getPingUrl($page))
  • No labels